docker如何部署mysql实现远程连接
1.dockersearchmysql查看mysql版本2.dockerpullmysql要选择starts最高的那个name进行下载3.dockerimages查看下载好的镜像4.启动mysql实例dockerrun--namedockermysql-p3307:3306-emysql_root_password=my-secret-pw-dmysql--name为mysql的实例设置别名。-p3307为对外暴露的端口。3306是内部端口-emysql_root_password设置mysql登录密码-
1.docker search mysql 查看mysql版本

2.docker pull mysql 要选择starts最高的那个name 进行下载
3.docker images 查看下载好的镜像
4.启动mysql实例
docker run --name dockermysql -p 3307:3306 -e mysql_root_password=my-secret-pw -d mysql
--name 为mysql的实例设置别名。 -p 3307为对外暴露的端口。3306是内部端口
-e mysql_root_password 设置mysql登录密码 -d 以守护进程运行(后台运行) 最后的mysql是镜像名称
5. docker ps -a 查看在运行的

6. docker exec -it dockermysql bash 进入容器内部 dockermysql 是上边运行时为容器取的别名 也可以用id替代
7.docker mysql -u root -p 然后直接输入密码即可 密码是在运行时设置的

use mysql
8.grant all privileges on *.* to 'root'@'%' ; 给用于授予权限
grant all privileges on *.* ‘root'@'%' identified by ‘123123' with grant option; 这是网上流传较多的写法。实际上会报错的。
9.flush privileges; 刷新权限
10.登录

11.mysql远程连接报错:authentication plugin caching_sha2
mysql 8.0 默认使用 caching_sha2_password 身份验证机制 —— 从原来的 mysql_native_password 更改为 caching_sha2_password。
从 5.7 升级 8.0 版本的不会改变现有用户的身份验证方法,但新用户会默认使用新的 caching_sha2_password 。
客户端不支持新的加密方式。
方法之一,修改用户的密码和加密方式
alter user 'root'@'%' identified with mysql_native_password by '密码';
要同赋予用户权限时相同。 若是localhost就同上。%也是如此
mysql8.*的新特性 caching_sha2_password 密码加密方式
以前版本的mysql密码加密使用的是 mysql_native_password
新添加的用户密码默认使用的 caching_sha2_password
如果在以前mysql基础上升级的 就得用户使用的密码加密使用的是 mysql_native_password
如果使用以前的密码加密方式,就修改文件 /etc/my.cnf
数据库时区问题:
链接数据库时servertimezone=utc这个参数出的问题
只要改成servertimezone=asia/shanghai就ok了!
Windows 10 是一款微软推出的经典操作系统,拥有硬件兼容性与多任务处理能力。它更偏向把系统状态查看和常用调节动作放在一起,适合需要持续观察和微调设备状态的场景。
极度公式是一款跨平台专业LaTeX公式识别编辑软件,支持OCR公式识别和多平台编辑。和使用说明,避免使用,享受完整功能与稳定支持。做扫描整理、文字提取和表格转换时,它能把识别后的处理步骤接得更顺,资料录入这类场景会省下不少时间。
















